Degraded performance for bank transfer in Nigeria

Incident Report for EBANX

Resolved

We are currently experiencing instability with our Nigerian banking partners responsible for processing bank transfers. Our team is actively monitoring the situation and working with partners to restore full service as soon as possible.
Posted May 15, 2025 - 19:48 UTC

Identified

We are currently experiencing instability with our Nigerian banking partners responsible for processing bank transfers. Our team is actively monitoring the situation and working with partners to restore full service as soon as possible.
Posted May 15, 2025 - 18:54 UTC